
Microsoft Windows Media Player


Microsoft® Windows Media™ Player 6.4
Legal Notice

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, people and events depicted herein are fictitious and no association with any real company, organization, product, person or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 1999-2000 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows Media, Windows NT, ActiveSync, ActiveX, Direct3D, DirectDraw, DirectInput, DirectMusic, DirectPlay, DirectShow, DirectSound, DirectX, FrontPage, JScript, Microsoft Press, MSN, NetShow, Outlook, PowerPoint, Visual Basic, Visual C++, Visual InterDev, Visual J++, Visual Studio, WebTV, Win32, and Win32s are either registered trademarks or trademarks of Microsoft Corporation in the U.S.A. and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.

This software is based in part on the work of the Independent JPEG Group.

GIF decompression code, copyright 1990, David Koblas. Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation. This software is provided "as is" without express or implied warranty.

Contents


1Introducing Microsoft Windows Media Player


2Windows Media Player components


3Windows Media Player controls


4Understanding the status line


6Using Windows Media Player


13Windows Media Player concepts


16Digital media formats supported by Windows Media Player


16Using keyboard shortcuts


18Accessibility features in Windows Media Player




Introducing Microsoft Windows Media Player

Microsoft® Windows Media™ Player is a universal media player you can use to receive audio, video, and mixed-media files in most popular formats.

Use Windows Media Player to listen to or view live news updates or broadcasts of your favorite sports team, to review a music video on a Web site, to "attend" a concert or seminar, or to preview clips from a new movie. 

Take a look at the features that make Windows Media Player the most comprehensive, simple, and efficient multimedia player:

High-quality multimedia experience

Windows Media Player can provide continuous viewing even when playing a file that consists of multiple media types. In addition, it supports intelligent streaming, which monitors network conditions and automatically makes adjustments to ensure the best reception and playback.

Easily tailored to meet your preferences

Windows Media Player is flexible enough that you can specify which features and controls appear. You can quickly change the size of the video window and even enlarge it to full-screen size. 

Simplified playing of a wide range of file types

In the past, each media file format required its own player, which you had to download and configure. With the new Windows Media Player, you can play streaming media files from the Internet or a local area network in addition to local multimedia file types: all from one, easy-to-use player. Windows Media Player can also play packaged media files created by Windows Media Packager.

Quick access to media content

The Favorites menu provides some quick links to interesting content and a simple way to add links for your favorite programming and media files. To gain access to more media files, click the Media Guide button or the Music button on the Navigation bar. To access radio stations, click the Radio button.

Windows Media Player components

The view you select and the file you are playing determine which components appear in the Player window. The following components can be displayed:

Navigation bar

Includes Forward and Back buttons to open digital media files you played earlier in the session and the Media Guide, Music, and Radio buttons, which provide access to a wide range of media files.

Video area

Displays the video content of the file that is playing. This can include advertising banners.

Captioning area

Displays closed captioning, if provided in the media file. This area appears only if you have selected Captions on the View menu and if you have Internet Explorer 4.0 or later installed.

Seek bar

Indicates the progress of the current clip. When content makes the Seek bar available, you can drag the progress indicator to select a place in the clip to start playing.

Controls

The Play, Pause, Stop, Skip Forward, Skip Backward, Rewind, Fast Forward, Preview, Mute, and Volume Control controls work the same as the controls on a compact disc player.

Go To bar

Displays a list of markers in the media file; the markers are much like tracks on a compact disc. Not all media files have markers. When you select a marker from the list, Windows Media Player begins playing the section of the media file associated with that marker.

Display area

Can contain the following information, if it is included in the media file: show title, clip title, author, and copyright.

Status line

Displays the current status of the Player (for example, connecting, buffering, playing, or paused), reception quality, the elapsed time and total time (if applicable) of the file playing, and icons for sound and closed captioning.

Windows Media Player controls

The Player controls appear below the video area in the Player window, if they are included in the current view. Depending on the file you are playing, some of the controls may not be available.

	This 
control
	Does this
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Play
	Begins playing the open media file. By default, a file begins to play automatically when it is opened.
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Pause
	Pauses the open media file. 
Click Play to resume.
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Stop
	Stops the playback of the current file. Stop does not close the file or your connection to a server.
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Skip Back
	Returns to the beginning of the current clip or, if at the beginning, returns to the beginning of the previous clip. Only available if the clip is part of a show.
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Rewind
	Rewinds the current clip. Only available with certain types of stored (not live) media. When you release the Rewind button, Windows Media Player begins playing again.
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Fast Forward
	Advances forward through the clip. Only available with certain types of stored (not live) media. When you release the Fast Forward button, Windows Media Player begins playing again.
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Skip Forward
	Begins playing the beginning of the next clip. Only available if a show is open.
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Preview
	Plays a short section of each clip in a show. Usually, each clip plays for 10 seconds, but an individual show may have a different preview duration. 
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Mute
	Silences the audio content of the file. Click Mute again to hear the soundtrack. The Mute button is unavailable if your computer does not have a sound card or sound driver installed.
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Volume
Control
	Controls the volume level of the content you are viewing. The volume slider is unavailable if your computer does not have a sound card or sound driver installed. The volume slider does not appear if the content has no soundtrack.


Understanding the status line

The status line shows the current activity of the Player (such as connecting, playing, paused, or buffering) and the quality of the reception. The status line also indicates the elapsed time and total time (if applicable) in a clip, the audio status (mono, stereo, or no audio), and whether the content is accompanied by closed captioning.

The status icons, which indicate the current activity and playback quality, are described below. If you point to the status icon in the Player window, a message displays the reception quality and the current bit and frame rates. 

	This 
icon
	Means this
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	Windows Media Player is opening the selected media file.
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	Windows Media Player is connecting to the requested server.
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	Windows Media Player is buffering, which means that it is storing media content to play. Buffering prevents skips in the playback of the media file.
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	Windows Media Player is able to receive the highest video bandwidth, or 100% of the transmitted video content. Video quality is excellent. 
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	Windows Media Player is receiving the lower video bandwidth (fewer kilobits per second), or 80-99% of the transmitted video content. Video quality is adequate.
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	Windows Media Player is receiving only part of the lower video bandwidth, or about 60-79% of the transmitted video content. Video quality is poor.
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	Windows Media Player is playing the audio content only because it is receiving too little (40-59%) of the video content.
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	Windows Media Player is receiving less than 40% of the content of the media file, and is therefore unable to play the file.


Using Windows Media Player

To find media files on the Web

Most of the time, you play streaming media files by clicking a link in a Web page. The Favorites menu contains several preset links to Web pages with interesting content. To gain access to more media files, click the Media Guide button or the Music button on the Navigation bar. To access radio stations, click the Radio button.

To play media files

Click a link in a Web page that points to the media content you want to play, or double-click a media file or icon in Windows Explorer or on your desktop. 

-or-

If you know the URL or path to a streaming media file or a stored multimedia file you want to play, click the File menu, click Open, and then type the URL or path. Or click Browse to search for the file.

To save an open non-streaming media file, click the File menu, click Save As, and then type the path and name where you want to save the file. Save As is unavailable if the file is a streaming media file.

To play a media file repeatedly

On the View menu, click Options.
On the Playback tab, click Play, and then type the number of times you want to play files.

Note   To play a file repeatedly until you stop the playback or close Windows Media Player, click Repeat forever. 

To navigate to marked sections in a media file

Sometimes media files will contain markers, which are like tracks on a compact disc. When you select a marker from a list, Windows Media Player begins playing the section of the media file associated with that marker.

On the Play menu, click Go To. 
Double-click the marker indicating the section you want to begin playing.

Tip   If the Go To bar appears in the Player window, you can open the list of markers by clicking the arrow in the Go To bar.

To use the Seek bar

The Seek bar appears above the controls in the Player window, if it is included in the current view and media file. The Seek bar indicates the progress of the current clip. 

To select a place in the clip to start playing, drag the progress indicator on the Seek bar. You can move backward or forward in a clip.

Note   The Seek bar is unavailable in some media files and if media content is live.

To adjust the volume

Use the UP ARROW and DOWN ARROW keys on the keyboard to raise and lower the volume or drag or click the volume control slider if it appears in the Player window. 

To mute the sound

Press CTRL+M or click the Mute button if it appears in the Player window.

To change the size of the video area

To resize the video area, do one of the following:

· Point to the side or corner of the Player window and drag it in any direction.

· On the View menu, click Zoom, and then click a setting: 50%, 100%, or 200%. The original size of a video is 100%.

· On the View menu, click Full Screen to display the video in the entire screen. Press ESC to return to the previous video size.

To automatically open the video area to a specific size

Whenever a new clip opens, Windows Media Player automatically resizes the Player window to the last zoom setting you selected. If you want the Player to open the video area to a specific size whenever a new clip opens, do the following:

On the View menu, click Options.
On the Player tab, clear the Autozoom player check box.

On the Playback tab, select the Zoom size you want to use.

To change the appearance of the Player window

The view you select determines which components of the Player appear in the Player window. Windows Media Player provides a choice of three views: Standard (which is not customizable), Compact, and Minimal. 

On the View menu, click the view that you want to use.

To change what appears in the Player window 

On the View menu, click Options.
Click the Custom Views tab. 

Click the components you want in the Compact and Minimal views.

To view closed captioning

On the View menu, click Captions, if it is available. Not all media files provide closed captioning. To turn captioning off, click Captions again. 

Note   When captioning is turned on, the Player window is expanded vertically, allowing space below the video area for the captioning text. However, the size of the video may decrease.

To add the open media file to your Favorites list

On the Favorites menu, click Add to Favorites.
If you want to, type a new name for the media file. 

If you want to place it in a particular folder, click Create In, and then click the folder.

To organize your favorite media files into folders

On the Favorites menu, click Organize Favorites.
If you need a new folder, click Create Folder, type a name for the folder, and then press ENTER.

Click the file you want to move, click Move to Folder, and then click the folder you want.

To play a favorite media file

On the Favorites menu, click the file you want to play.

To run Windows Media Player from an MS-DOS prompt or command line

In the command prompt, type mplayer2. The Player window opens. 

To start playing a specific media file as soon as the Player window opens, type the path or URL to the media file after the command mplayer2. For example:

· mplayer2 http://webserver/directory/file name 

· mplayer2 drive:\directory\file name

To preview items in a show

A show is a list of one or more clips that play in order when the media file is opened. Not all media files contain a show.

On the Play menu, click Preview to play a short section of each clip in a show. Usually, each clip plays for 10 seconds, but an individual show may have a different preview duration.

You can also preview a show by clicking the Preview button in the controls of the Player window.

Note   To move to the previous and next clips in a show, click the Skip Forward and Skip Back buttons in the controls (or click Skip Back and Skip Forward on the Play menu). This action stops the preview of clips in the show.

To play media files you played earlier in a session

On the Navigation bar near the top of the Player window, click the Back or Forward button to play media files from a list of files you played earlier in the current session of Windows Media Player.

Note   The Back button is unavailable until you have played multiple files in the current session of Windows Media Player. The Forward button is unavailable until you have used the Back button.

To change video playback settings

From the View menu, point to Settings, and then select Microsoft MPEG-4 Video Decompressor.

· To improve picture quality, slide the CPU slider to a higher level setting. Make sure not to overload your computer's processing ability.

· To change the brightness of the video, move the Brightness slider toward 0 to decrease the brightness or toward 100 to increase the brightness. Brightness reflects the amount of white in the video content.

· To change the contrast in the video, move the Contrast slider toward 0 to decrease the contrast or toward 100 to increase the contrast. Increasing the contrast makes a video appear sharper; however, the frames render with increased choppiness. Decreasing the contrast can make a video appear smoother, but some of the details will be lost.

· To change the color saturation of the video, move the Saturation slider toward 0 to decrease the saturation or toward 100 to increase the saturation. With increased saturation, the colors become more vivid. Decreased saturation moves the video toward the gray scale. 

· To change the hue of the video, move the Hue slider toward 0 to move the hues toward the green end of the color scale or toward 100 to move toward the violet end of the color scale. Changing the hue will produce different effects; use the hue to correct tones that differ slightly from your expectations. 

After you have made the changes you want, click Apply to apply the setting to the current video stream. 

Note   The video playback settings are only available if the content was encoded with the Microsoft MPEG4 video codec.

To change Windows Media playback settings

From the View menu, point to Settings, and then select Windows Media Source Filter.
To change the amount of data Windows Media Player buffers before it begins to play back content, click Buffer and then enter the number of seconds that you want to buffer. Click Use default buffering to buffer 3 seconds of data.

Select which protocols are used to receive Windows Media files in the Protocols section. When connecting to content, Windows Media Player attempts to connect with all available protocols before returning a failure to connect message. 

If you have connection through HTTP enabled, you can manually configure your proxy server settings. If you do not use a proxy server, proxy server settings can be disabled. If you do not know your proxy server setting, Windows Media Player can access the proxy server settings used by your browser. 

Click Apply to apply your settings to the current content. 

Note   The Windows Media Audio settings are only available if you are playing Windows Media content.

To change Microsoft Audio Decoder settings

From the View menu, point to Settings, and then select Microsoft Audio Decoder.
Adjust the sliders for the frequency ranges to suit the needs of the content. Lower frequency ranges adjust bass sounds; upper frequency ranges adjust treble sounds. The Spectrum graph at the top shows you the relative strengths of the signals.

Click Apply to apply the settings to the current audio stream, or click Reset to reset the settings to the default values.

Note   The audio playback settings are only available if the content was encoded with the Window Media Audio codec.

To change MPEG Layer-3 Decoder settings

From the View menu, point to Settings, and then select MPEG Layer-3 Decoder.
Click the Statistics tab to view the statistic for the playback of the .mp3 file.

Click the Quality tab to modify the following playback properties:

· Frequency. Change the percentage of signal frequency played back, choose either Full, Half or Quarter.

· Resolution. Change the amount of sound depth by selecting either 16 Bit or 8 Bit.

· Stereo Mode. Choose how the stereo channels are received, either full Stereo or Downmix.

· CPU Type. Select which type of computer processor you are using to playback the file, either Pentium or 80486.

Click Apply to apply the settings to the current audio stream, or click Reset to reset the settings to the default values.

Note   On some computers, decoding of .mp3 files is too CPU intensive. If that is the case, the audio playback quality will be poor and skip sections. By lowering the settings on this tab, the processing load placed on your CPU is lowered and the quality of audio playback is improved. These audio playback settings are only available if the content was encoded with the MPEG Layer-3 Audio codec.

To get the most recent version of Windows Media Player

On the Help menu, click Check for Player Upgrade. (You must have an open connection to the Internet to perform this check.)

If a newer version is available, click Upgrade Now to download the new version.

Note   Windows Media Player periodically checks for new versions automatically. If it finds that an upgrade is available, the upgrade dialog box appears, and you can click Upgrade Now. If you do not want to be interrupted with the upgrade dialog box in the future, clear the Notify me of any player upgrades check box in the upgrade dialog box. 

If a new version of Windows Media Player is available, but you choose not to upgrade, an Upgrade menu is added to your menu bar as a reminder.

Windows Media Player concepts

Streaming media

Streaming media is an audio, video, or multimedia file, transmitted across a network, that Windows Media Player can begin playing with little delay, instead of waiting to download an entire file before playing it. As a streaming media file is transmitted to your computer, part of the file is stored in memory before playback begins. While the file plays, Windows Media Player stores other parts of the stream to play.

Windows Media Player also supports intelligent streaming, which monitors network conditions and automatically makes adjustments to ensure the best reception and playback.

Buffering

When buffering occurs, Windows Media Player stores part of the media file in memory, and then plays it at the appropriate time. Usually, when Windows Media Player opens a media file, it buffers for a short time and then begins playing the file. While the Player is playing a file, it is typically buffering other parts of the file, to be played a little later. Buffering prevents skips and pauses in the playback of media files.

Clip

A clip is an individual audio, video, or multimedia file. 

Show

A show is a collection of one or more clips that play in order when a media file is opened. A clip is an individual audio, video, or multimedia file.

View

A view is an arrangement of the components that appear in the Player window. The components are the video area, the Seek bar, the Go To bar, the controls, the display area, and the status line.

The components in Standard view are preset and cannot be changed. The other two views (Compact view and Minimal view) can be changed to meet your needs and preferences.

Intelligent streaming

Intelligent streaming is a Microsoft Windows Media technology that automatically detects network conditions and adjusts the properties of a video stream to maximize quality. This technology was developed because Internet connections are highly variable in terms of actual throughput achieved for any specific connection and range of possible connection speeds; this variability can have a deleterious effect on the reception of streaming media. Intelligent streaming depends on content being encoded at multiple bit rates. This gives Windows Media Player a variety of video streams to switch to when available network bandwidth fluctuates.

Intelligent streaming uses the following strategies when streaming content to the Player: 

At connection, the server and client automatically determine the current available bandwidth, and then the server selects and serves the video stream at the appropriate bit rate. 
During transmission, if the available bandwidth decreases, the server automatically detects the change and switches to a lower bandwidth stream. If bandwidth improves, the server switches to a higher bandwidth stream.

If bandwidth can no longer support streaming video, intelligent streaming attempts to maintain a continuous audio stream and decreases the video frame rate to minimize interruptions caused by buffering. If the bit rate is still too high, the server stops sending video frames, resulting in an audio-only stream. If audio quality starts to degrade, the client attempts to reconstruct portions of the stream to preserve quality.

Packaged content

Packaged content is an audio-only .asf or .wma file that has been encrypted using Windows Media Packager. A packaged file can only be decrypted if the user has the proper decryption key. Keys are provided to users along with a license when a consumer registers with the content provider.

Understanding packaged content

Digital rights management (DRM) is the technology for securing content and managing the rights for its access. Windows Media-based content that has been encrypted and secured is known as packaged content. Windows Media Player cannot play packaged content without a valid license. When Windows Media Player opens a packaged file, it first checks if there is a license on the computer that provides the rights required to play the content. If the computer does not have a valid license, the browser opens and navigates to the license registration page of the content provider's Web site. A license is issued after you complete the registration information, and then Windows Media Player plays the content. 

You can play packaged content until the license expires. You will be informed during license download of the terms of the license. A license can be for an unlimited time, a set amount of time, or a set number of playbacks depending on how the content provider set up the license. However, if you copy the content to another computer or give a copy of the file to another person, registration will have to occur on that computer as well. Licenses and decryption keys cannot be copied and shared among different computers. 

When Windows Media Player plays packaged content, you will see the following items:

· The content title

· The artist name

· A copyright notice

· A banner image 

· Video images

· A legitimacy icon, indicating that the content is protected and has not been tampered with

In addition, clicking different areas of the window opens your Web browser to predefined Web sites. For example, clicking the banner image might open the content provider's Web site, and clicking the title might open the artist's Web site. 

Digital media formats supported by Windows Media Player

The following types of media files can be played by Microsoft Windows Media Player. When you open a stored file that has one of the extensions listed below, either by double-clicking a file icon or a link in a Web page, Windows Media Player starts.

· Microsoft Windows Media formats. File name extensions: .avi, .asf, .asx, .rmi, .wav, .wma, .wax

· Moving Pictures Experts Group (MPEG). File name extensions: .mpg, .mpeg, .m1v, .mp2, .mp3, .mpa, .mpe

· Musical Instrument Digital Interface (MIDI). File name extensions: .mid, .rmi

· Apple QuickTime, Macintosh AIFF Resource. File name extensions: .qt, .aif, .aifc, .aiff, .mov

· UNIX formats. File name extensions: .au, .snd

Note   To view or change properties for a specific media format, begin playing a file using that media format, click the View menu, and then click Settings.

Using keyboard shortcuts

	Press 
this
	To do this

	SPACEBAR
	Play or pause an open media file.

	PERIOD
	Stop the Player.

	PAGE UP
	Restart current clip or play previous clip (Skip Back).

	PAGE DOWN
	Play next clip in playlist (Skip Forward).

	ESC
	Return to previous size from full-screen mode and stop the Player, or stop the Player.

	LEFT ARROW 
	Momentary rewind. Rewind stops when you release the key.

	CTRL + LEFT ARROW
	Continuous rewind. Rewind continues until you select another control.

	RIGHT ARROW 
	Momentary fast forward. Fast forwarding stops when you release the key.

	CTRL + RIGHT ARROW
	Continuous fast forward. Fast forwarding continues until you select another control.

	ALT + LEFT ARROW
	Open the previous media file you played in this session.

	ALT + RIGHT ARROW
	Open the next media file in the list of files played in this session.

	M or CTRL+M
	Turn sound off or on.

	UP ARROW
	Turn volume up.

	DOWN ARROW
	Turn volume down.

	ALT + ENTER
	Use full-screen mode or return to previous size from full-screen mode.

	ALT+1
	Resize video to 50%.

	ALT+2
	Resize video to 100%.

	ALT+3
	Resize video to 200%.

	CTRL+1 
	Use Standard view.

	CTRL+2
	Use Compact view.

	CTRL+3
	Use Minimal view.

	CTRL+HOME
	Open a Web site that provides access to a wide range of all types of media files.

	CTRL+F
	Open a Web site that provides access to Web based radio stations.

	CTRL+G
	Select a marker at which to begin playback.

	CTRL+O
	Open a file.

	CTRL+T
	Put Windows Media Player on top of other windows.

	CTRL+U
	Open a Web site that provides access to a wide range of music.

	CTRL+V
	Preview a section of each clip in the playlist.

	SHIFT+F10
	Open the context menu.


Accessibility features in Windows Media Player

The following features make Windows Media Player more accessible for people with disabilities:

Keyboard access

You can gain access to all Windows Media Player features by using the keyboard or the mouse. For more information about keyboard access, see Using keyboard shortcuts.
Closed captioning

You can display closed captioning in Microsoft SAMI (Synchronized Accessible Media Interchange) format or scripted closed captioning directly below the video area. 

Predefined simplified views

Windows Media Player includes two simplified views of the components in the Player window. You can customize these views to fit your needs and preferences. 

Resizable Player window

You can quickly change the size of the video window and even enlarge it to a full screen.
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